Kommentare (0)

Es wurden noch keine Kommentare gepostet.

UpdateServerupdate auf 1.12.2

SanX

verfasst von

[Admin]

SanX

am 25.08.2018 um 22:11



Eigentlich wollte ich den Server gleich auf 1.13 updaten und mir erst gar nicht die Mühe machen, auf 1.12.2 zu updaten. Doch nun läuft der Server trotzdem auf 1.12.2 und das Update auf 1.13 wird frühestens in einem Jahr oder niemals kommen. Warum?

Nach kurzer Recherche musste ich feststellen, dass in der Bukkit-API Block-IDs gänzlich abgeschafft werden sollen und noch dazu das ganze Material-Enum umstrukturiert werden soll. Heißt also, dass viele Plugins nur mehr begrenzt mit 1.13 kompatibel sein werden. Die meisten Plugins werden aktiv weiterentickelt und geupdated, aber einige wenige eben nicht mehr. Server, die von solchen Plugins abhängig sind, können also nicht auf 1.13 updaten.

Für Neostralis sind die Plugins kein großes Problem, da die meisten selbst geschrieben sind und mit etwas Mühe geupdated werden können. Schwierigkeiten wird der ganze Questcode bereiten.

Aber bis ein Update auf 1.13 überhaupt möglich sein wird, kann noch Monate dauern. Es ist noch kein stabiles Release von Spigot für 1.13 verfügbar und Plugins wie Dynmap, WorldEdit oder NoCheatPlus müssen auch erst von den Developern geupdated werden. Optifine für 1.13 ist btw auch noch nicht released. Ich schätze daher, dass viele Server sehr spät oder nie auf 1.13 updaten werden.

Ich wünsche euch allen und vor allem den LabyMod-Fans viel Vergnügen auf Neostralis mit 1.12.2!

Zurück zum Archiv